Width

Current State: 
Rejected
GUID: 
2ceb290a-55c6-40b4-a91b-0df3681f6520
Data Type: 
LENGTH
Visible: 
1
User Modifiable: 
1

Comments

This is a duplicate of a system Parameter. Should be removed or renamed.

It has been proposed to rename this parameter, along with all other generic dimensions, to avoid confusion with system parameters: http://openrfa.org/forum/topic/avoid-using-system-parameter-names-shared...

We are proposing to rename the parameters to include "Overall" as a prefix, so this parameter would be reanmed to OverallWidth. Thoughts?

There's already a set of parameters in the Dimension Group For the purpose of reporting the overall dimensions of a family with the intent being to normalize the values for schedules and tags.  They are UnitDiameter, UnitRadius, UnitDepth, UnitWidth, etc.  The problem with them and the use of "Overall" or parameters such as "Depth"is that they're too generic and cause problems with trying to maintain consistency b/t families, schedules, and tags.  For example an AHU with round connections may need separate diameter parameters for the supply, return, and exhaust connections.

What your thoughts on something like "NominalDiameter", "ReportingDiameter", or "IdentificationDiameter"? Where the intent is extract whatever diameter (i.e. the inlet neck diameter for various air terminals) for identification in tags and schedules?  We need parameters generic enough to span multiple types of equipment, but specific enough so that content providers know to use them for reporting and identification purposes and not for driving the actual dimensions within the family.

Unit as a modifer is not as clear as Overall. It only makes sense if you are talking about piece of equipment. Some of us (like Architects) don't deal with pieces of equipment. And what does nominal mean? Why give a nominal dimension if you are also providing an exact dimension? 

l don't think the answer is to have "parameters generic enough to span multiple types of equipment" but to have a hierarchy of parameters - general to specific. 

e.g.

WidthOverall

WidthActual

WidthClearance

WidthMyBossToldMeToMakeThis

What if we rename UnitWidth to WidthOverall (the same goes for all of the Unit____ parameters)? Then it would be generic enough for architects and engineers use.

I agree that it would be convenient to have generic and specific parameters for things like width, but is there a better way? I think you both bring up good points, but from an end-user perspective, I might get confused with a generic parameter.

For example, what if we were to build a rectangular ceiling diffuser family. I might need multiple width parameters: WidthGrilleFace and WidthDuct. Having a WidthOverall might confuse me.

From an architectural side, can you give us an example of want you might use WidthOverall for?

Introducing collaborative shared parameters.

Join OpenRFA to help build the new master shared parameters for Revit.