QuantityFailureMode2

Current State: 
Proposed
GUID: 
92365649-439c-4374-af25-e002e30bd149
Data Type: 
INTEGER
Group: 
Mechanical
Visible: 
1
Description: 
Number of components within a unit to remain operational during Failure Mode
User Modifiable: 
1

Comments

We have a similar parameter and the naming convention doesn't seem to match. Please see QuantityUnitsPeak.

Also, how does this differ from QuantityFailureMode?

Perhaps this should be renamed to QuantityUnitsFailure?

I intended this to differ from QuantityFailureMode in that it refers to the number of components within a unit that remain operational, rather than simply the number of units. For example, QuantityFailureMode may refer to the number of fan arrays operational during failure mode, while QuantityFailureMode2 would refer to the number of individual fans within each array that remain operational.

Thanks for the feedback. This makes sense. Maybe we should get additional opinions on this, but I am leaning towards naming these parameters like so:

  • QuanityUnitsFailure
  • QuantityUnitComponentsFailure

Thoughts?

That's a tough one.  I would keep QuantityUnitsFailureMode since its referring to the quanitity of units operating during failure mode.  Without "Mode" it would be easy to mistake the parameter to mean the quantity that has failed.

How about QuanityFanUnitsPeak for the 2nd since it only used with fan arrays?  

 

Introducing collaborative shared parameters.

Join OpenRFA to help build the new master shared parameters for Revit.